エージェントの作成方法
エージェントの新規作成手順は以下の通りです。
- 左サイドバーの[メニュー]を押して表示されるメニューリストから[エージェント(RAG)]を押し、エージェントメニューを開きます。
- メニュー上部の[+]を押すことで作成メニューが展開されます。
- エージェント名や参照ファイル、モデル、ベースプロンプトなど、各項目を設定します。
- [エージェント作成]を押すと、エージェント作成が完了します。
エージェントの設定項目
基本設定
-
エージェント名:エージェントの名前を入力します。
-
エージェント紹介文:利用者に向けて、エージェントの概要や使い方などを入力します。
- アイコン画像:任意の画像を選択するか、プリセットからアイコンを設定します。
共同編集者
共同編集者を設定できます。
- 参考ヘルプ:エージェントの共同編集
参照ファイル設定
エージェントの回答時に参照させるファイルを登録します。
ファイルは、新しくアップロードするか、ストレージに登録されている既存のファイルから選択できます。
アップロードできるファイル形式
- docx
- xlsx
- csv
- ppt
- pptx
- pptm
- json
- md (Markdown)
- txt
ファイル数上限
- 80ファイル
サイズ上限
- 50MB
Tips💡複数ファイルのアップロード
ドラッグ&ドロップで複数のファイルをまとめてアップロードすることができます。
参照ソースの取得数設定
エージェントにアップロードしたファイルの参照ソース取得数を調整できます。
AIの応答が正しくファイル参照できていないと感じる場合は、段階的に参照ソース数を増やすと応答精度が改善される可能性があります。
※参照ソース数が多くなると消費クレジットも増加します。
参照ソース取得数の調整方法
- ファイルをアップロードした状態で[参照ソースの取得数設定]をクリックします。
- 参照ソースの取得数設定メニューで適切な参照数を選択して[保存]をクリックします。
※「プロンプトに応じて自動調整」がONの状態が初期設定で、従来と同等の振る舞いになります。
※自動調整をOFFにすると、参照ソースの取得率を設定することが可能です。
参照ソースの詳細のチャット表示設定
エージェント利用時に応答チャットの文末に表示される「ファイルの参照ソース数」を非表示にできます。
アップロードしたファイルの内容を、エージェント利用者に開示したくない場合にご利用ください。
※「参照ソースの詳細」が非表示になるだけで、ファイル参照は設定に関わらず実施されます。
簡易解析ファイルの説明文を自動生成
簡易解析の参照ファイルを設定している場合、エージェントの設定保存時に「ファイル説明文」のない参照ファイルの説明文をAIで自動生成するか選択できます。
ファイル説明文があることで、複数ファイル参照時の精度が向上しますので、1つのエージェントに複数ファイルを参照設定している場合は、説明文を自動生成することをおすすめします。
ファイル説明文の自動生成の利用方法
- 「エージェントを作成」メニューを開きます。
- 参照ファイルをアップロードします。
解析方法の選択が必要な場合は「簡易解析」を選択します。
- [エージェント作成]をクリックします。
- 「ファイル説明文の自動生成確認」ポップアップで[自動生成して設定保存]をクリックします。
応答・プロンプト設定
「モデル」を選択し、「ベースプロンプト」に任意のプロンプトを入力します。
必要に応じて、WEB検索の利用設定などを設定します。
「検索結果URL (参考情報)」のチャット表示設定
WEB検索実行時に、応答チャットの文末に表示される「検索結果のURL一覧(参考情報)」を非表示にできます。
※ 検索結果が非表示になるだけで、WEB検索は実施されます。
ベースプロンプト作成サポート
目的や役割、応答方針などを入力するだけで、利用者の意図をAIが理解し、最適なベースプロンプトを自動生成します。
ベースプロンプト作成サポートの利用方法
- ベースプロンプト入力フォーム右下の[プロンプト作成サポート]を押します。
- ベースプロンプト作成サポートに必要な情報を入力して[作成]を押します。
- プロンプト確認ポップアップ右下の[プロンプトを設定]を押します。
注意事項
- 参考ファイルにアップロードできるファイルは1つのみです。
- 参考ファイルはエージェントの参照ファイルには設定されません。
高度なオプション:ワークフロー(条件分岐)を設定
エージェントの実行前または実行後に、条件に応じて指定したアクションを実行するワークフローを設定できます。
- 参考ヘルプ:エージェント条件分岐
オプション:RAGリンク利用設定
RAGリンクの利用条件や、利用者による画像添付の可否を設定できます。
- 参考ヘルプ:【RAGリンク】エージェントを手軽に利用したい
エージェントの編集・削除
エージェントの編集手順は以下の通りです。
- 左サイドバーの[メニュー]を押して表示されるメニューリストから[エージェント(RAG)]を押し、エージェントメニューを開きます。
- エージェントの一覧から編集したいエージェント名にマウスを移動させ、表示される[編集]アイコンを押すと、編集メニューが展開されます。
- 「エージェント名」「エージェント紹介文」「アイコン画像」「参照ファイル設定」「モデル」「ベースプロンプト」を編集します。
- [設定保存]を押すと、エージェントの編集が完了します。
エージェントを削除する場合には、編集メニューの左下の[削除]を押し、
「エージェントを削除」ポップアップ画面で[削除]を押すと完了します。
エージェントの利用方法
エージェントの利用手順は以下の通りです。
- チャット入力フォームの[エージェント選択]を押すと、利用可能なエージェントが表示されます。
- 使いたいエージェントを選択すると、 チャット入力フォームの上にエージェント名が表示されます。
- チャットを送信すると、そのエージェントから回答が出力されます。